TROMjaro Forum

Update fails every time

We installed TROMjaro as we did on other laptops with other distros.
Whenever we try to accept the updates, we get “Failed to prepare transaction - missing or Impaired database”.
We don`t even understand if the database on our laptop or that of our mirror could be “impaired”, everything else works fine.
we update through the terminal, but there is always more in the software-center.
Sorry if my english is not good enough, any idea to fix our update-manager would be appreciated.
Thank you, Jorgen

One more: updating via terminal we get: vala-panel-appmenu-common and vala-panel-appmenu-common-git are in conflict.
So again, no preparation to update, but maybe a hint?
Thank you for your attention


Please see this TROMjaro 2022.11.18 (basic system updates)

Let me know if that fixes it.

Did not work. We took those out, and tried installing updates even one by one. Always same answer about missing or impaired database.
We will download a the iso again and install TROMjaro a second time. See you then and thanks for your support

Ok make sure you check the hash values after you download it to make sure it has downloaded fully. We have tested the latest ISO on several machine and in VMs and all works ok. Let us know. We are here to help of course.

I had the same error and turning off the updates for those packages fixed it.

However when I now try to use the Tromjaro layout switcher and it asks for my password it keeps saying I am entering the wrong password along with this error message:

“Failed installing vala-panel-appmenu-registrar-git !\nmake sure that you typed the password correctly or that you are not currently installing or updating your system\nEnabling the internet connection might solve the issue”

Any way to fix this?

It is not ok to hold packages from updating. This was an issue with a previous ISO we released. You need to remove the tromjaro-layout-switcher package then, if you still have any vala-panel-appmenu package remove those too. Only after that refresh your database form Add/Remove Software and reinstall the TROMjaro Layout Switcher.