TROMjaro Forum

Unable to update. Some sort of keyring problem

Hi guys,

I cant’t install any updates for a little bit over a week or so. At first I played the waiting game if updates get changed and work like many times before in manjaro. But that time it seems like something is wrong on my system.
Using pamac results in a failure:

Herunterladen von tblock-gui (1.3.4-3)...
Überprüfe Schlüsselring...
Integrität wird überprüft...
Fehler: autokey-common: signature from "TNE <>" is unknown trust
Fehler: autokey-gtk: signature from "TNE <>" is unknown trust
Fehler: beaver-notes: signature from "TNE <>" is unknown trust

sudo pacman -Syu

:: Datei /var/cache/pacman/pkg/tblock-gui-1.3.4-3-any.pkg.tar.zst ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] j
Fehler: Der Vorgang konnte nicht durchgeführt werden (Ungültiges oder beschädigtes Paket)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

I tried refreshing keys but it did not work:

sudo pacman-key --refresh-keys
gpg: öff. Schlüssel des ultimativ vertrauten Schlüssel 78A826CFA3068B9C nicht gefunden

Seems like my system can’t get the “ultimate trusted key”?
Never had any issues like that before.

System is a pretty fresh install and only a few programms got installed (official repos and aur).


Did you try ?

gpg --recv-key 78A826CFA3068B9C
1 Like
gpg --recv-key 78A826CFA3068B9C
gpg: Empfangen vom Schlüsselserver fehlgeschlagen: Keine Daten

Seems to not receive any data. Internet works fine on the machine.

I never used gpg, but probably people solved it :thinking:

also github issue is connected with the page on above: [Bug] signature from "TNE <>" is invalid · Issue #2699 · chaotic-aur/packages · GitHub

if I understood currectly:
This Person changed key(ID or signature?) to: D6C9442437365605

it’s seems to try this one:
gpg --recv-keys D6C9442437365605

gpg --keyserver --recv-keys D6C9442437365605

without quotes ofc

1 Like

Followed the instructions of the link and was finally able to update my packages :slight_smile:

Thanks very much! But how did that happen? That page is 10 month old…

I am happy you fixed it with the help of @usoft ! As to why it happens it may be because some key changes…

1 Like

What is difference betwean key-servers?
Ubuntu has one.

They just provide a copies of a public keys?
Even if keys are not for Ubuntu?