TROMjaro Forum

Glitching and artifacts at bootup for AMD/ATI GPU users

Hi Tio and forum. Ran a search for this issue in the forum here but couldn’t find anyone else with a similar problem or any fixes mentioned so sorry if a solution has already been posted, but if so anyway, great!

Just installed TROMjaro not long ago on a machine with an old AMD Radeon HD6450 GPU and i get screen artifacts at bootup. For me, the glitches go away after about 5-10 seconds after login, but it is annoying especially when the whole screen goes completely multicolour pixelated, but how it looks after each bootup can be random.

I would like to solve this issue if i can not only to help me but knowing it will help others if fixed so will provide a bit of history about this issue. Sharebay’s Colin Turner also received a similar issue on his AMD laptop with Ubuntu Studio, another XFCE distro some years ago except his issue sounded worse and more prevailing than mine. I wasn’t able to help him then in time so he just gave up as he didn’t have the time for it so he just installed Windows 10 on it. Oh dear! But i guess i couldn’t blame him.

For Colin, at first i thought the issue was due to not having a correct AMD GPU driver installed as it wouldn’t show in the driver setup menu for him. Later i learned that the AMD GPU driver can be baked into the kernel so will already be installed for you, so as a result that likely wasn’t the cause of the problem for him, and it’s likely not for me either.

Thus why it didn’t show in the driver menu. I am aware that can sometimes happen also with Intel GPU’s, possibly if the driver is already preinstalled and in the kernel already which i’m aware Intel does with their drivers. That’s why you don’t normally need to install Intel GPU drivers in Linux yourself (just some knowledge to share for new Linux users there who are unaware).

So before posting here i did try and see if i could fix this issue myself to see if i can get rid of it entirely and i was going to share here of the results.

I discovered the issue is caused by a bug in the compositor in the XFCE desktop environment that distros like TROMjaro uses. If you turn the compositor off in TROMjaro, yep you guessed it, it boots into the system fine after login with 0 artifacting, except now you have to put up with screen tearing on fast moving images, scrolling, or when moving windows around…Oh joy!

And with that i know some TROMjaro users won’t be able to live with that, i’m one of them and would much rather not switch to another desktop environment and only use that if i can. I want to fix this issue whilst still having a compositor enabled, i like the way TROMjaro is set up and looks. But if i can’t fix it, i may still have to, and advise others against installing TROMjaro if you are an AMD GPU user and will probably suggest Manjaro with another desktop environment (not XFCE or default Manjaro) for them to at least to come close to the TROMjaro experience. I have ran other distros before with this GPU and i cannot recall ever seeing this problem on other desktop environments.

So what have a tried to fix it? Switched off the XFCE compositor in the windows tweak menu and installed Compiz and followed the instructions on the internet to enable the workaround options it has in its config and sadly no joy. Also followed instructions on the internet to use Compton instead. No joy. Still problems. The Picom fork of Compton doesn’t fix it either. Upgrading the kernel to the latest currently available (V6.0) in the kernel manager also didn’t help.

It was then i came across this link here: [SOLVED] xfce compositor: Transparency graphic artifacts - Testing Branch - Manjaro Linux Forum

This suggested i could try two things. So first i tried changing the compositor to use xpresent by entering this line into the terminal: xfconf-query -c xfwm4 -p /general/vblank_mode -t string -s "xpresent" --create

At first i thought that worked after first reboot, but then subsequent reboots, the artifacts would return, though it’s difficult to say if it improved anything any. I haven’t noticed it engulfing the entire screen with coloured pixels or at least not really badly like before, so maybe it helped but only a little?

I also then tried what it suggested at the bottom of the link changing the value to xpresent in the xfwm4.xml file (located in /etc/skel/.config/xfce4/xfconf/xfce-perchannel-xml/xfwm4.xml) so it shows as: <property name="vblank_mode" type="string" value="xpresent"/>

Instead of: <property name="vblank_mode" type="string" value="auto"/>

Sadly that didn’t get rid of the artifacting completely either. So as you can probably tell, i’m stumped. Any ideas? I really want to stick with TROMjaro, and its current desktop if i can. I am enjoying it and would love to suggest it to others. But if i can’t get any help here, there probably is nothing more i can do. Thanks for the suggestions.


Oh boy this sounds like a very bad bug. And it is the first time I hear about it. First of all much appreciated the fact that you tried to fix it and the suggestions you made in the post.

Now, I have two laptops with AMD and none resulted in this ugly mess. Thing is, if this is an issue, it is likely an XFCE issue and therefore way beyond TROMjaro and what we can do.

Here are some suggestions:

  1. Try with a different kernel. You can easily change it in TROMjaro if you have some access to the desktop.
  2. Report the issue to XFCE directly so that they can advise you and ask you to try and debug. Either report for xfdesktop or xfwm4.
  3. Use their forums, they are often very helpful. Read this forum post too.

If you turn the compositor off in TROMjaro, yep you guessed it, it boots into the system fine after login with 0 artificating, except now you have to put up with screen tearing on fast moving images, scrolling, or when moving windows around…Oh joy!

And again this is why I recommend to report to them. A big XFCE release is due to december this year, after 2 years of work. Maybe that will fix it. You can try installing from AUR the git versions of their desktop and see if that fixes it.

Another thing you can try, from TTY rename the folder .config/xfce4 where the xfce-related settings are stored. See if that changes anything.

Sorry I do not have a solution for this, but I also cannot reproduce it and test it on anything really. And it is very likely this is an issue with XFCE not specifically TROMjaro. They need to fix this ugly bug for this particular GPU config.

1 Like

Any reason why you picked compiz? I would’ve tried picom first.

Also I am on an all AMD machine and have none of the artifact issues you are having.
In fact Tromjaro is running faster, lighter and better than EndevourOS (i3), Pop!OS, Arcolinux i3, MX Linux, ModiciaOS and Ubuntu 22.04 ever has.
image
If I ever get rid of Tromjaro it will only be to go back EndevourOS (i3). Simply because its the only one that has i3 set up to be beautiful out of the box.

1 Like

I did try picom but i forgot about it since i uninstalled it since it didn’t work and couldn’t recall its name. I was actually not aware of picom at first because i’m less familiar with the Manjaro ways of doing things of being further ahead. I’m used to point releases being on those distros longer, not rolling. And had taken a break from using Linux for about a year and finding Windows 11 on the old machine to be too slow, so figured i’d finally give TROMjaro a proper shot on it after only trying it in live mode on it or in a VM previously on another machine.

With that i would have missed things. I was not aware compton was now fazed out. I was trying to find compton being made aware of that from trying Ubuntu Mate a previous time and was already aware of compiz from the old Ubuntu unity days so figured i’d try that too. I did eventually find compton anyway after trying picom but later found it was named under something else (compton-old-git) since it’s no longer in the works and forked under picom.

I did try Endevour once on one of my machines but found it difficult to figure how to install apps on it being used to having a more readily available app store. I’ve heard things might have changed with that distro now though and it is now more accessible than it was back when i tried it, but haven’t tried it again since then to know for sure.

1 Like

Ah thanks anyway. I’ve installed the Budgie desktop on it from the Add/Remove Software app now and yes can confirm no artifacting or screen tearing with that desktop environment. Of course, if anything changes bugs or solutions-wise, i will report of any outcomes here.

1 Like

Would be greatly useful to report these bugs so that they fix them. This seems like an edge/rare case. If you report it to them then you help others too, don’t forget that :slight_smile:

1 Like