TROMjaro Forum

App launcher and cursor keys

A suggestion.

Now you can do “Super”, begin to type your app name, and then use “Tab” to go to the suggested apps space, and use cursor keys+enter to select the app you want to launch.

I think that using the cursor keys directly when you are in the search text field is much more user frienly than have to use tab and then the cursor keys.

Great OS! Regards.

I’ve just been playing with this now and see what you mean. There is some inconsistent behaviour with the Whisker menu after typing in a search. When I first tried it, I had the same result as you whereby the expected Down Arrow didn’t navigate the list before first pressing Tab. However I found a workaround to this is to first press the Up arrow, which also works to focus the search results just as well as the Tab key.
Then after playing with it a bit more, it is now allowing me to navigate the search results immediately with the Down Arrow without having to press either Up or Tab first. Do it a few times / quickly and you may find this too. Might be something worth reporting to the Whisker menu people.

An alternative work around would be to use the included Application Finder instead of the Whisker menu as your program launcher. This seems to work consistently with the Down arrow to select results. I thought this was actually what the Super key was set to launch by default when I first installed TROMjaro :thinking:

1 Like

Thank you! I’ll keep trying.

1 Like

P.S. If you wish to try out using the Application Finder instead, you can set it in the Keyboard settings. Here is what mine look like so far:

I am pretty sure the Super L key was first set to app finder by default for me, and I had to manually add the Whisker Menu entry which is why it shows the full path here.

1 Like

If I get you right, what you mean is that when you press the super key and type the name of an app you’d like to simply use the arrow keys and select it. Now you have to press the down arrow key twice to have it work. It is a limitation that the developer of this Application Finder could not find a fix for. We talked a lot and it is not as easy as it may see. For now, instead of pressing the tab, press the down arown key and then you can select form the menu.

The Application Finder does not have this issue for me. I don’t need to press either tab or the down key twice, I can either hit enter to launch the top option, or the down key once to select the second option and so on. All perfectly as expected :slight_smile:

Yes if you want to select the first option, but if you need any other option you can’t go left for example, you have to go down, then you have control over the selector.

Apologies if I have totally confused this thread in my own confusion. My brain does not work at its best in my current state of health. I haven’t even managed to say hello properly yet which should have been my first post! (I will try to do that soon).

I couldn’t understand why one would want to go left or right until I realised after more playing with it now that it must be because you have the “View items as icons” option checked in the Application Finder preferences. So you have a grid of options within which you can navigate to the left and right. (I always change settings to my own preferences so quickly that I forget how things are set by default).

Assuming this is correct, then perhaps @kinu could try how they find the experience after unchecking the “View items as icons” option. This gives you a simple vertical list of results which can be navigated immediately with the up and down arrows without any delay.


Thank you all. Now I can choose between having it as a list and use only the down key, or having it as icons and use the down key (once, it works for me) and then the left key, that is enough functional and quick for me.